成功解决Microsoft visual c++ 14.0 is required问题~~

avatar 2020年1月12日18:32:38 评论 217

加入VIP,可以享受无广告视频播放!更可享受教程提前看!详情猛戳:VIP介绍

我是在安装scrapy时遇到这个问题的,安装其他组件也可能会遇到。但问题解决办法都是大致相同的。

问题截图(为了这个截图,我又把之前安装好的东西卸载了,就是这么用心~):

成功解决Microsoft visual c++ 14.0 is required问题~~

这个问题的大概意思就是没有安装Microsoft Visual C++ 14.0,但是根据它上面给的链接,也安装不了,在百度上搜“Microsoft Visual C++ 14.0 安装”,看到了几个CSDN里的资源,但是还要积分,而我一个刚刚开始接触CSDN的新手,哪里有积分啊,所以果断放弃,看完了网上的教程,发现没有几个是适合我的,所以自己摸索出一个方法,如下:

1. 安装twisted

这是因为在我安装scrapy时,提示信息里写到需要安装twisted,但是在我尝试用pip install twisted时,还是会出现"Microsoft Visual C++ 14.0 is required"的问题。

于是我想起来,还有一种安装组件的方法,那就是在组件库里先下载需要的组件,然后再安装。下载地址为:https://www.lfd.uci.edu/~gohlke/pythonlibs/

成功解决Microsoft visual c++ 14.0 is required问题~~

找到合适自己的版本下载(如:python3.7,64位版本,选择最后一个下载)。

pip install C:\Users\new\Downloads\Twisted-18.7.0-cp37-cp37m-win_amd64.whl

后面的是你下载的组件路径,这样就可以完成安装twisted。

2.安装scrapy

可以尝试pip install scrapy,如果出错,也按照上面的方式进行安装,即可解决这个问题。

 

 

 

———————————————
版权声明:本文为CSDN博主「ttliu_kiwi」的原创文章,遵循CC 4.0 BY-SA 版权协议,转载请附上原文出处链接及本声明。
原文链接:https://blog.csdn.net/ting0922/article/details/82355663

 

 

感谢大家的收看,我们下期再见!

avatar

发表评论

您必须才能发表评论!